What’s Vulnerable › Vulnerabilities
CVE-2023-37582: Apache RocketMQ: Possible remote code execution when using the update configuration function
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 90.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-94
Description
The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1. When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as. It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.
Affected products
- Apache Software Foundation Apache RocketMQ: through 4.9.6; from 5.0.0 through 5.1.1
References
- http://www.openwall.com/lists/oss-security/2023/07/12/1
- https://lists.apache.org/thread/m614czxtpvlztd7mfgcs2xcsg36rdbnc
- http://www.openwall.com/lists/oss-security/2023/07/12/1
- https://lists.apache.org/thread/m614czxtpvlztd7mfgcs2xcsg36rdbnc
Get alerted when CVE-2023-37582 or the next vulnerability affects your stack