What’s Vulnerable › Vulnerabilities
CVE-2023-37623
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Netdisco before v2.063000 was discovered to contain a cross-site scripting (XSS) vulnerability via the component /Web/TypeAhead.pm.
Affected products
- Netdisco: before 2.063000 — fixed in 2.063000
How to fix
Upgrade to a fixed version: Netdisco 2.063000. Check the vendor advisory for mitigations.
References
- https://github.com/benjaminpsinclair/Netdisco-2023-Advisory
- https://github.com/benjaminpsinclair/Netdisco-CVE
- https://github.com/netdisco/netdisco/commit/39562e0633a2472d50f7f33e69c36da4ad1fbfa3
- https://github.com/netdisco/netdisco/commit/9f4401f2fb00c84210cd551b97c8ad60e78c71e0
- https://github.com/benjaminpsinclair/Netdisco-2023-Advisory
- https://github.com/benjaminpsinclair/Netdisco-CVE
- https://github.com/netdisco/netdisco/commit/39562e0633a2472d50f7f33e69c36da4ad1fbfa3
- https://github.com/netdisco/netdisco/commit/9f4401f2fb00c84210cd551b97c8ad60e78c71e0
Get alerted when CVE-2023-37623 or the next vulnerability affects your stack