What’s Vulnerable › Vulnerabilities
CVE-2023-37858: PHOENIX CONTACT: Use of Hard-coded Credentials in WP 6xxx Web panels
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-09 · updated 2026-06-17
- Weakness: CWE-311
Description
In PHOENIX CONTACTs WP 6xxx series web panels in versions prior to 4.0.10 an authenticated, remote attacker with admin privileges is able to read hardcoded cryptographic keys allowing to decrypt an encrypted web application login password.
Affected products
- Phoenixcontact Wp 6070-Wvps Firmware: before 4.0.10 — fixed in 4.0.10
- Phoenixcontact Wp 6101-Wxps Firmware: before 4.0.10 — fixed in 4.0.10
- Phoenixcontact Wp 6121-Wxps Firmware: before 4.0.10 — fixed in 4.0.10
- Phoenixcontact Wp 6156-Whps Firmware: before 4.0.10 — fixed in 4.0.10
- Phoenixcontact Wp 6185-Whps Firmware: before 4.0.10 — fixed in 4.0.10
- Phoenixcontact Wp 6215-Whps Firmware: before 4.0.10 — fixed in 4.0.10
How to fix
Upgrade to a fixed version: Phoenixcontact Wp 6070-Wvps Firmware 4.0.10; Phoenixcontact Wp 6101-Wxps Firmware 4.0.10; Phoenixcontact Wp 6121-Wxps Firmware 4.0.10; Phoenixcontact Wp 6156-Whps Firmware 4.0.10; Phoenixcontact Wp 6185-Whps Firmware 4.0.10; Phoenixcontact Wp 6215-Whps Firmware 4.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-37858 or the next vulnerability affects your stack