What’s Vulnerable › Vulnerabilities

CVE-2023-37900: Crossplane vulnerable to denial of service from large image

Description

Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, a high-privileged user could create a Package referencing an arbitrarily large image containing that Crossplane would then parse, possibly resulting in exhausting all the available memory and therefore in the container being OOMKilled. The impact is limited due to the high privileges required to be able to create the Package and the eventually consistency nature of controller. This issue is fixed in versions 1.11.5, 1.12.3, and 1.13.0.

Affected products

How to fix

Upgrade to a fixed version: crossplane 1.11.5, 1.12.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-37900 or the next vulnerability affects your stack