What’s Vulnerable › Vulnerabilities
CVE-2023-37901: Cross-Site-Scripting via confirmation prompts
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Indico is an open source a general-purpose, web based event management tool. There is a Cross-Site-Scripting vulnerability in confirmation prompts commonly used when deleting content from Indico. Exploitation requires someone with at least submission privileges (such as a speaker) and then someone else to attempt to delete this content. Considering that event organizers may want to delete suspicious-looking content when spotting it, there is a non-negligible risk of such an attack to succeed. The risk of this could be further increased when combined with some some social engineering pointing the victim towards this content. Users need to update to Indico 3.2.6 as soon as possible. See the docs for instructions on how to update. Users who cannot upgrade should only let trustworthy users manage categories, create events or upload materials ("submission" privileges on a contribution/event). This should already be the case in a properly-configured setup when it comes to category/event management. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.
Affected products
- indico: before 3.2.6 — fixed in 3.2.6
How to fix
Upgrade to a fixed version: indico 3.2.6. Check the vendor advisory for mitigations.
References
- https://docs.getindico.io/en/stable/installation/upgrade/
- https://github.com/indico/indico/commit/2ee636d318653fb1ab193803dafbfe3e371d4130
- https://github.com/indico/indico/releases/tag/v3.2.6
- https://github.com/indico/indico/security/advisories/GHSA-fmqq-25x9-c6hm
- https://docs.getindico.io/en/stable/installation/upgrade/
- https://github.com/indico/indico/commit/2ee636d318653fb1ab193803dafbfe3e371d4130
- https://github.com/indico/indico/releases/tag/v3.2.6
- https://github.com/indico/indico/security/advisories/GHSA-fmqq-25x9-c6hm
Get alerted when CVE-2023-37901 or the next vulnerability affects your stack