What’s Vulnerable › Vulnerabilities
CVE-2023-37904: Discourse Race Condition in Accept Invite
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-28 · updated 2026-06-17
- Weakness: CWE-362
Description
Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, more users than permitted could be created from invite links. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. As a workaround, use restrict to email address invites.
Affected products
- discourse: before 3.0.6; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+205) — fixed in 3.0.6
How to fix
Upgrade to a fixed version: discourse 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/62a609ea2d0645a27ee8adbb01ce10a5e03a600b
- https://github.com/discourse/discourse/security/advisories/GHSA-6wj5-4ph2-c7qg
- https://github.com/discourse/discourse/commit/62a609ea2d0645a27ee8adbb01ce10a5e03a600b
- https://github.com/discourse/discourse/security/advisories/GHSA-6wj5-4ph2-c7qg
Get alerted when CVE-2023-37904 or the next vulnerability affects your stack