What’s Vulnerable › Vulnerabilities
CVE-2023-37905: Cross-site Scripting (XSS) in Source Mode of Editor in ckeditor-wordcount-plugin
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
ckeditor-wordcount-plugin is an open source WordCount Plugin for CKEditor. It has been discovered that the `ckeditor-wordcount-plugin` plugin for CKEditor4 is susceptible to cross-site scripting when switching to the source code mode. This issue has been addressed in version 1.17.12 of the `ckeditor-wordcount-plugin` plugin and users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Ckeditor-Wordcount-Plugin Project Ckeditor-Wordcount-Plugin: before 1.17.12 — fixed in 1.17.12
How to fix
Upgrade to a fixed version: Ckeditor-Wordcount-Plugin Project Ckeditor-Wordcount-Plugin 1.17.12. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-m8fw-p3cr-6jqc
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/commit/0f03b3e5b7c1409998a13aba3a95396e6fa349d8
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/commit/a4b154bdf35b3465320136fcb078f196b437c2f1
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4
- https://typo3.org/security/advisory/typo3-core-sa-2023-004
- https://github.com/TYPO3/typo3/security/advisories/GHSA-m8fw-p3cr-6jqc
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/commit/0f03b3e5b7c1409998a13aba3a95396e6fa349d8
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/commit/a4b154bdf35b3465320136fcb078f196b437c2f1
- https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4
- https://typo3.org/security/advisory/typo3-core-sa-2023-004
Get alerted when CVE-2023-37905 or the next vulnerability affects your stack