What’s Vulnerable › Vulnerabilities
CVE-2023-37906: Discourse vulnerable to DoS via post edit reason
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-28 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can edit a post in a topic and cause a DoS with a carefully crafted edit reason. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.0.6; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+205) — fixed in 3.0.6
How to fix
Upgrade to a fixed version: discourse 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/dcc825bda505a344eda403a1b8733f30e784034a
- https://github.com/discourse/discourse/security/advisories/GHSA-pjv6-47x6-mx7c
- https://github.com/discourse/discourse/commit/dcc825bda505a344eda403a1b8733f30e784034a
- https://github.com/discourse/discourse/security/advisories/GHSA-pjv6-47x6-mx7c
Get alerted when CVE-2023-37906 or the next vulnerability affects your stack