What’s Vulnerable › Vulnerabilities
CVE-2023-37917: Privilege Escalation in kubepi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-21 · updated 2026-06-17
- Weakness: CWE-269
Description
KubePi is an opensource kubernetes management panel. A normal user has permission to create/update users, they can become admin by editing the `isadmin` value in the request. As a result any user may take administrative control of KubePi. This issue has been addressed in version 1.6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- 1Panel-dev KubePi: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: 1Panel-dev KubePi 1.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/KubePi/security/advisories/GHSA-757p-vx43-fp9r
- https://github.com/1Panel-dev/KubePi/security/advisories/GHSA-757p-vx43-fp9r
Get alerted when CVE-2023-37917 or the next vulnerability affects your stack