What’s Vulnerable › Vulnerabilities
CVE-2023-37924: Apache Submarine: SQL injection from unauthorized login
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-22 · updated 2026-06-17
- Weakness: CWE-89
Description
Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login. Now we have fixed this issue and now user must have the correct login to access workbench. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins. If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image to fix this.
Affected products
- Apache Software Foundation Apache Submarine: from 0.7.0 before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Submarine 0.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/submarine/pull/1037
- https://issues.apache.org/jira/browse/SUBMARINE-1361
- https://lists.apache.org/thread/g99h773vd49n1wyghdq1llv2f83w1b3r
- https://github.com/apache/submarine/pull/1037
- https://issues.apache.org/jira/browse/SUBMARINE-1361
- https://lists.apache.org/thread/g99h773vd49n1wyghdq1llv2f83w1b3r
Get alerted when CVE-2023-37924 or the next vulnerability affects your stack