What’s Vulnerable › Vulnerabilities
CVE-2023-37930
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-908
Description
Multiple issues including the use of uninitialized ressources [CWE-908] and excessive iteration [CWE-834] vulnerabilities vulnerability in Fortinet allows a VPN user to corrupt memory potentially leading to code or commands execution via specifically crafted requests.
Affected products
- Fortinet FortiOS (FortiGate): from 6.4.7 before 6.4.15; from 7.0.1 before 7.0.13; from 7.2.0 before 7.2.6; 7.4.0 — fixed in 6.4.15, 7.0.13, 7.2.6
- Fortinet FortiProxy: from 7.0.0 before 7.0.13; from 7.2.0 before 7.2.7 — fixed in 7.0.13, 7.2.7
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.4.15, 7.0.13, 7.2.6; Fortinet FortiProxy 7.0.13, 7.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-37930 or the next vulnerability affects your stack