What’s Vulnerable › Vulnerabilities

CVE-2023-37940

Description

Cross-site scripting (XSS) vulnerability in the edit Service Access Policy page in Liferay Portal 7.0.0 through 7.4.3.87, and Liferay DXP 7.4 GA through update 87, 7.3 GA through update 29, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into a service access policy's `Service Class` text field.

Affected products

How to fix

Upgrade to a fixed version: Liferay Digital Experience Platform 7.3; Liferay Portal 7.4.3.88. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-37940 or the next vulnerability affects your stack