What’s Vulnerable › Vulnerabilities
CVE-2023-37941: Apache Superset: Metadata db write access can lead to remote code execution
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 35.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-502
Description
If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.
Affected products
- Apache Superset: from 1.5.0 through 2.1.0
References
- http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html
- https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h
- http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html
- https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h
Get alerted when CVE-2023-37941 or the next vulnerability affects your stack