What’s Vulnerable › Vulnerabilities

CVE-2023-38057: XSS stored in survey answers

Description

An improper input validation vulnerability in OTRS Survey modules allows any attacker with a link to a valid and unanswered survey request to inject javascript code in free text answers. This allows a cross site scripting attack while reading the replies as authenticated agent. This issue affects OTRS Survey module from 7.0.X before 7.0.32, from 8.0.X before 8.0.13 and ((OTRS)) Community Edition Survey module from 6.0.X through 6.0.22.

Affected products

How to fix

Upgrade to a fixed version: OTRS AG Survey 7.0.32, 8.0.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-38057 or the next vulnerability affects your stack