What’s Vulnerable › Vulnerabilities
CVE-2023-38097: NETGEAR ProSAFE Network Management System BkreProcessThread Exposed Dangerous Function Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-749
Description
NETGEAR ProSAFE Network Management System BkreProcessThread Exposed Dangerous Function Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of NETGEAR ProSAFE Network Management System. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed. The specific flaw exists within the BkreProcessThread class. The issue results from an exposed dangerous function. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. . Was ZDI-CAN-19719.
Affected products
- NETGEAR ProSAFE Network Management System: before 1.7.0.20 — fixed in 1.7.0.20
How to fix
Upgrade to a fixed version: NETGEAR ProSAFE Network Management System 1.7.0.20. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065707/Security-Advisory-for-Multiple-Vulnerabilities-on-the-ProSAFE-Network-Management-System-PSV-2023-0024-PSV-2023-0025
- https://www.zerodayinitiative.com/advisories/ZDI-23-919/
- https://kb.netgear.com/000065707/Security-Advisory-for-Multiple-Vulnerabilities-on-the-ProSAFE-Network-Management-System-PSV-2023-0024-PSV-2023-0025
- https://www.zerodayinitiative.com/advisories/ZDI-23-919/
Get alerted when CVE-2023-38097 or the next vulnerability affects your stack