What’s Vulnerable › Vulnerabilities
CVE-2023-38112: Foxit PDF Reader XFA Annotation Use-After-Free Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Foxit PDF Reader XFA Annotation Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of Annotation objects. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-21062.
Affected products
- Foxit PDF Reader: through 10.1.12.37872; from 11.0.0 through 11.2.6.53790; from 12.0.0 through 12.1.2.15332; before 11.1.4.1121; from 12.0.0.0601 before 12.1.0.1229 — fixed in 11.1.4.1121, 12.1.0.1229
- Foxit Pdf Reader: through 12.1.2.15332; before 12.1.0.1229 — fixed in 12.1.0.1229
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.1.4.1121, 12.1.0.1229; Foxit Pdf Reader 12.1.0.1229. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-23-990/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-23-990/
Get alerted when CVE-2023-38112 or the next vulnerability affects your stack