What’s Vulnerable › Vulnerabilities
CVE-2023-38125: Softing edgeAggregator Permissive Cross-domain Policy with Untrusted Domains Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-942
Description
Softing edgeAggregator Permissive Cross-domain Policy with Untrusted Domains Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Softing edgeAggregator. Authentication is required to exploit this vulnerability. The specific flaw exists within the configuration of the web server. The issue results from the lack of appropriate Content Security Policy headers. An attacker can leverage this in conjunction with other vulnerabilities to execute code in the context of root. Was ZDI-CAN-20542.
Affected products
- Softing edgeAggregator: before 3.50 — fixed in 3.50
- Softing edgeConnector: before 3.50 — fixed in 3.50
- Softing Secure Integration Server: before 1.30 — fixed in 1.30
How to fix
Upgrade to a fixed version: Softing edgeAggregator 3.50; Softing edgeConnector 3.50; Softing Secure Integration Server 1.30. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-23-1059/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1059/
Get alerted when CVE-2023-38125 or the next vulnerability affects your stack