What’s Vulnerable › Vulnerabilities
CVE-2023-38406
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-06 · updated 2026-06-17
- Weakness: CWE-755
Description
bgpd/bgp_flowspec.c in FRRouting (FRR) before 8.4.3 mishandles an nlri length of zero, aka a "flowspec overflow."
Affected products
- FRRouting: before 8.4.3 — fixed in 8.4.3
How to fix
Upgrade to a fixed version: FRRouting 8.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/FRRouting/frr/compare/frr-8.4.2...frr-8.4.3
- https://github.com/FRRouting/frr/pull/12884
- https://lists.debian.org/debian-lts-announce/2024/04/msg00019.html
- https://github.com/FRRouting/frr/compare/frr-8.4.2...frr-8.4.3
- https://github.com/FRRouting/frr/pull/12884
- https://lists.debian.org/debian-lts-announce/2024/04/msg00019.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00007.html
Get alerted when CVE-2023-38406 or the next vulnerability affects your stack