What’s Vulnerable › Vulnerabilities
CVE-2023-38407
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-06 · updated 2026-06-17
Description
bgpd/bgp_label.c in FRRouting (FRR) before 8.5 attempts to read beyond the end of the stream during labeled unicast parsing.
Affected products
- FRRouting: before 8.5 — fixed in 8.5
How to fix
Upgrade to a fixed version: FRRouting 8.5. Check the vendor advisory for mitigations.
References
- https://github.com/FRRouting/frr/compare/frr-8.5-rc...frr-8.5
- https://github.com/FRRouting/frr/pull/12951
- https://github.com/FRRouting/frr/pull/12956
- https://lists.debian.org/debian-lts-announce/2024/04/msg00019.html
- https://github.com/FRRouting/frr/compare/frr-8.5-rc...frr-8.5
- https://github.com/FRRouting/frr/pull/12951
- https://github.com/FRRouting/frr/pull/12956
- https://lists.debian.org/debian-lts-announce/2024/04/msg00019.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00007.html
Get alerted when CVE-2023-38407 or the next vulnerability affects your stack