What’s Vulnerable › Vulnerabilities

CVE-2023-38427

Description

An issue was discovered in the Linux kernel before 6.3.8. fs/smb/server/smb2pdu.c in ksmbd has an integer underflow and out-of-bounds read in deassemble_neg_contexts.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 5.15.145, 6.1.34, 6.3.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-38427 or the next vulnerability affects your stack