What’s Vulnerable › Vulnerabilities
CVE-2023-38430
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in the Linux kernel before 6.3.9. ksmbd does not validate the SMB request protocol ID, leading to an out-of-bounds read.
Affected products
- Linux kernel: from 5.15 before 5.15.145; from 5.16 before 6.1.35; from 6.2 before 6.3.9 — fixed in 5.15.145, 6.1.35, 6.3.9
- NetApp H300S: all versions
- NetApp H410S: all versions
- NetApp H500S: all versions
- NetApp H700S: all versions
- NetApp Hci Management Node: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.15.145, 6.1.35, 6.3.9. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.3.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/fs/smb/server?id=1c1bcf2d3ea061613119b534f57507c377df20f9
- https://security.netapp.com/advisory/ntap-20230831-0003/
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.3.9
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/fs/smb/server?id=1c1bcf2d3ea061613119b534f57507c377df20f9
- https://security.netapp.com/advisory/ntap-20230831-0003/
Get alerted when CVE-2023-38430 or the next vulnerability affects your stack