What’s Vulnerable › Vulnerabilities
CVE-2023-38494: The cloud version of the MeterSphere interface leaks some sensitive data without authentication
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-04 · updated 2026-06-17
- Weakness: CWE-200
Description
MeterSphere is an open-source continuous testing platform. Prior to version 2.10.4 LTS, some interfaces of the Cloud version of MeterSphere do not have configuration permissions, and are sensitively leaked by attackers. Version 2.10.4 LTS contains a patch for this issue.
Affected products
- metersphere: before 2.10.4 — fixed in 2.10.4
How to fix
Upgrade to a fixed version: metersphere 2.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/metersphere/metersphere/commit/a23f75d93b666901fd148d834df9384f6f24cf28
- https://github.com/metersphere/metersphere/security/advisories/GHSA-fjp5-95pv-5253
- https://github.com/metersphere/metersphere/commit/a23f75d93b666901fd148d834df9384f6f24cf28
- https://github.com/metersphere/metersphere/security/advisories/GHSA-fjp5-95pv-5253
Get alerted when CVE-2023-38494 or the next vulnerability affects your stack