What’s Vulnerable › Vulnerabilities
CVE-2023-38495: Crossplane vulnerable to possible image tampering from missing image validation for Packages
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-27 · updated 2026-06-17
- Weakness: CWE-20
Description
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.
Affected products
- crossplane: before 1.11.5; from 1.12.0 before 1.12.3 — fixed in 1.11.5, 1.12.3
How to fix
Upgrade to a fixed version: crossplane 1.11.5, 1.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/crossplane/crossplane/blob/ac8b24fe739c5d942ea885157148497f196c3dd3/security/ADA-security-audit-23.pdf
- https://github.com/crossplane/crossplane/security/advisories/GHSA-pj4x-2xr5-w87m
- https://github.com/crossplane/crossplane/blob/ac8b24fe739c5d942ea885157148497f196c3dd3/security/ADA-security-audit-23.pdf
- https://github.com/crossplane/crossplane/security/advisories/GHSA-pj4x-2xr5-w87m
Get alerted when CVE-2023-38495 or the next vulnerability affects your stack