What’s Vulnerable › Vulnerabilities
CVE-2023-38498: Discourse vulnerable to DoS via defer queue
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-28 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can prevent the defer queue from proceeding promptly on sites hosted in the same multisite installation. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability. Users of multisite configurations should upgrade.
Affected products
- discourse: before 3.0.6; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+205) — fixed in 3.0.6
How to fix
Upgrade to a fixed version: discourse 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/26e267478d785e2f32ee7da4613e2cf4a65ff182
- https://github.com/discourse/discourse/security/advisories/GHSA-wv29-rm3f-4g2j
- https://github.com/discourse/discourse/commit/26e267478d785e2f32ee7da4613e2cf4a65ff182
- https://github.com/discourse/discourse/security/advisories/GHSA-wv29-rm3f-4g2j
Get alerted when CVE-2023-38498 or the next vulnerability affects your stack