What’s Vulnerable › Vulnerabilities
CVE-2023-38499: typo3/cms-core Information Disclosure due to Out-of-scope Site Resolution
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-200
Description
TYPO3 is an open source PHP based web content management system. Starting in version 9.4.0 and prior to versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30, and 12.4.4, in multi-site scenarios, enumerating the HTTP query parameters `id` and `L` allowed out-of-scope access to rendered content in the website frontend. For instance, this allowed visitors to access content of an internal site by adding handcrafted query parameters to the URL of a site that was publicly available. TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30, 12.4.4 fix the problem.
Affected products
- typo3: from 9.4.0 before 9.5.42; from 10.0.0 before 10.4.39; from 11.0.0 before 11.5.30; from 12.0.0 before 12.4.4 — fixed in 10.4.39, 11.5.30, 12.4.4, 9.5.42
How to fix
Upgrade to a fixed version: typo3 10.4.39, 11.5.30, 12.4.4, 9.5.42. Check the vendor advisory for mitigations.
References
- https://github.com/TYPO3/typo3/commit/702e2debd4b28f9cdb540544565fe6a8627ccb6a
- https://github.com/TYPO3/typo3/security/advisories/GHSA-jq6g-4v5m-wm9r
- https://typo3.org/security/advisory/typo3-core-sa-2023-003
- https://github.com/TYPO3/typo3/commit/702e2debd4b28f9cdb540544565fe6a8627ccb6a
- https://github.com/TYPO3/typo3/security/advisories/GHSA-jq6g-4v5m-wm9r
- https://typo3.org/security/advisory/typo3-core-sa-2023-003
Get alerted when CVE-2023-38499 or the next vulnerability affects your stack