What’s Vulnerable › Vulnerabilities
CVE-2023-38501: copyparty vulnerable to reflected cross-site scripting via k304 parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
copyparty is file server software. Prior to version 1.8.7, the application contains a reflected cross-site scripting via URL-parameter `?k304=...` and `?setck=...`. The worst-case outcome of this is being able to move or delete existing files on the server, or upload new files, using the account of the person who clicks the malicious link. It is recommended to change the passwords of one's copyparty accounts, unless one have inspected one's logs and found no trace of attacks. Version 1.8.7 contains a patch for the issue.
Affected products
- 9001 copyparty: before 1.8.7 — fixed in 1.8.7
How to fix
Upgrade to a fixed version: 9001 copyparty 1.8.7. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/173821/Copyparty-1.8.6-Cross-Site-Scripting.html
- https://github.com/9001/copyparty/commit/007d948cb982daa05bc6619cd20ee55b7e834c38
- https://github.com/9001/copyparty/security/advisories/GHSA-f54q-j679-p9hh
- http://packetstormsecurity.com/files/173821/Copyparty-1.8.6-Cross-Site-Scripting.html
- https://github.com/9001/copyparty/commit/007d948cb982daa05bc6619cd20ee55b7e834c38
- https://github.com/9001/copyparty/security/advisories/GHSA-f54q-j679-p9hh
Get alerted when CVE-2023-38501 or the next vulnerability affects your stack