What’s Vulnerable › Vulnerabilities
CVE-2023-38504: Sails DoS vulnerability for apps with sockets enabled
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-27 · updated 2026-06-17
- Weakness: CWE-248
Description
Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.
Affected products
- balderdashy sails: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: balderdashy sails 1.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/balderdashy/sails/commit/4a023dc5095a4b30fdc8535f705ed34cd22d2f7d
- https://github.com/balderdashy/sails/pull/7287
- https://github.com/balderdashy/sails/releases/tag/v1.5.7
- https://github.com/balderdashy/sails/security/advisories/GHSA-gpw9-fwm8-7rx7
- https://github.com/balderdashy/sails/commit/4a023dc5095a4b30fdc8535f705ed34cd22d2f7d
- https://github.com/balderdashy/sails/pull/7287
- https://github.com/balderdashy/sails/releases/tag/v1.5.7
- https://github.com/balderdashy/sails/security/advisories/GHSA-gpw9-fwm8-7rx7
Get alerted when CVE-2023-38504 or the next vulnerability affects your stack