What’s Vulnerable › Vulnerabilities
CVE-2023-38506: Cross-site Scripting (XSS) when pasting HTML into the rich text editor in Joplin
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Joplin is a free, open source note taking and to-do application. A Cross-site Scripting (XSS) vulnerability allows pasting untrusted data into the rich text editor to execute arbitrary code. HTML pasted into the rich text editor is not sanitized (or not sanitized properly). As such, the `onload` attribute of pasted images can execute arbitrary code. Because the TinyMCE editor frame does not use the `sandbox` attribute, such scripts can access NodeJS's `require` through the `top` variable. From this, an attacker can run arbitrary commands. This issue has been addressed in version 2.12.10 and users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- laurent22 joplin: before 2.12.10 — fixed in 2.12.10
How to fix
Upgrade to a fixed version: laurent22 joplin 2.12.10. Check the vendor advisory for mitigations.
References
- https://github.com/laurent22/joplin/security/advisories/GHSA-m59c-9rrj-c399
- https://github.com/laurent22/joplin/security/advisories/GHSA-m59c-9rrj-c399
Get alerted when CVE-2023-38506 or the next vulnerability affects your stack