What’s Vulnerable › Vulnerabilities
CVE-2023-38507: Strapi Improper Rate Limiting vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-770
Description
Strapi is the an open-source headless content management system. Prior to version 4.12.1, there is a rate limit on the login function of Strapi's admin screen, but it is possible to circumvent it. Therefore, the possibility of unauthorized login by login brute force attack increases. Version 4.12.1 has a fix for this issue.
Affected products
- strapi: before 4.12.1 — fixed in 4.12.1
How to fix
Upgrade to a fixed version: strapi 4.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/strapi/strapi/blob/32d68f1f5677ed9a9a505b718c182c0a3f885426/packages/core/admin/server/middlewares/rateLimit.js#L31
- https://github.com/strapi/strapi/releases/tag/v4.12.1
- https://github.com/strapi/strapi/security/advisories/GHSA-24q2-59hm-rh9r
- https://github.com/strapi/strapi/blob/32d68f1f5677ed9a9a505b718c182c0a3f885426/packages/core/admin/server/middlewares/rateLimit.js#L31
- https://github.com/strapi/strapi/releases/tag/v4.12.1
- https://github.com/strapi/strapi/security/advisories/GHSA-24q2-59hm-rh9r
Get alerted when CVE-2023-38507 or the next vulnerability affects your stack