What’s Vulnerable › Vulnerabilities
CVE-2023-38510: Tolgee Lacks Permission Check for API Key for some endpoints
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-27 · updated 2026-06-17
- Weakness: CWE-862
Description
Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.
Affected products
- tolgee-platform: from 3.14.0 before 3.23.1 — fixed in 3.23.1
How to fix
Upgrade to a fixed version: tolgee-platform 3.23.1. Check the vendor advisory for mitigations.
References
- https://github.com/tolgee/tolgee-platform/commit/4776cba67e7bb8c1b0259376e3e5fa3bb46e45c7
- https://github.com/tolgee/tolgee-platform/pull/1818
- https://github.com/tolgee/tolgee-platform/releases/tag/v3.23.1
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-4f9j-4vh4-p85v
- https://github.com/tolgee/tolgee-platform/commit/4776cba67e7bb8c1b0259376e3e5fa3bb46e45c7
- https://github.com/tolgee/tolgee-platform/pull/1818
- https://github.com/tolgee/tolgee-platform/releases/tag/v3.23.1
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-4f9j-4vh4-p85v
Get alerted when CVE-2023-38510 or the next vulnerability affects your stack