What’s Vulnerable › Vulnerabilities

CVE-2023-38633

Description

A directory traversal problem in the URL decoder of librsvg before 2.56.3 could be used by local or remote attackers to disclose files (on the local filesystem outside of the expected area), as demonstrated by href=".?../../../../../../../../../../etc/passwd" in an xi:include element.

Affected products

How to fix

Upgrade to a fixed version: GNOME Librsvg 2.46.6, 2.48.11, 2.50.8, 2.52.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-38633 or the next vulnerability affects your stack