What’s Vulnerable › Vulnerabilities
CVE-2023-38647: Apache Helix: Deserialization vulnerability in Helix workflow and REST
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-26 · updated 2026-06-17
- Weakness: CWE-502
Description
An attacker can use SnakeYAML to deserialize java.net.URLClassLoader and make it load a JAR from a specified URL, and then deserialize javax.script.ScriptEngineManager to load code using that ClassLoader. This unbounded deserialization can likely lead to remote code execution. The code can be run in Helix REST start and Workflow creation. Affect all the versions lower and include 1.2.0. Affected products: helix-core, helix-rest Mitigation: Short term, stop using any YAML based configuration and workflow creation. Long term, all Helix version bumping up to 1.3.0
Affected products
- Apache Software Foundation Apache Helix: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Helix 1.3.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/zyqxhv0lc2z9w3tgr8ttrdy2zfh5jvc4
- https://lists.apache.org/thread/zyqxhv0lc2z9w3tgr8ttrdy2zfh5jvc4
Get alerted when CVE-2023-38647 or the next vulnerability affects your stack