What’s Vulnerable › Vulnerabilities
CVE-2023-3865: ksmbd: fix out-of-bound read in smb2_write
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-16 · updated 2026-08-15
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix out-of-bound read in smb2_write ksmbd_smb2_check_message doesn't validate hdr->NextCommand. If ->NextCommand is bigger than Offset + Length of smb2 write, It will allow oversized smb2 write length. It will cause OOB read in smb2_write.
Affected products
- Linux kernel: from 5.15 before 5.15.121; from 5.16 before 6.1.36; from 6.2 before 6.3.10; 6.4-rc1, 6.4-rc2, 6.4-rc3, 6.4-rc4, 6.4-rc5, 6.4-rc6 (+1) — fixed in 5.15.121, 6.1.36, 6.3.10
How to fix
Upgrade to a fixed version: Linux kernel 5.15.121, 6.1.36, 6.3.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3813eee5154d6a4c5875cb4444cb2b63bac8947f
- https://git.kernel.org/stable/c/58a9c41064df27632e780c5a3ae3e0e4284957d1
- https://git.kernel.org/stable/c/5fe7f7b78290638806211046a99f031ff26164e1
- https://git.kernel.org/stable/c/c86211159bc3178b891e0d60e586a32c7b6a231b
Get alerted when CVE-2023-3865 or the next vulnerability affects your stack