What’s Vulnerable › Vulnerabilities
CVE-2023-38677: FPE in paddle.linalg.eig
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-369
Description
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
Affected products
- paddlepaddle/paddle: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: paddlepaddle/paddle 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-009.md
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-009.md
Get alerted when CVE-2023-38677 or the next vulnerability affects your stack