What’s Vulnerable › Vulnerabilities
CVE-2023-38684: Discourse vulnerable to ossible DDoS due to unbounded limits in various controller actions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-28 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, in multiple controller actions, Discourse accepts limit params but does not impose any upper bound on the values being accepted. Without an upper bound, the software may allow arbitrary users to generate DB queries which may end up exhausting the resources on the server. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.0.6; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+205) — fixed in 3.0.6
How to fix
Upgrade to a fixed version: discourse 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/bfc3132bb22bd5b7e86f428746b89c4d3d7f5a70
- https://github.com/discourse/discourse/security/advisories/GHSA-ff7g-xv79-hgmf
- https://github.com/discourse/discourse/commit/bfc3132bb22bd5b7e86f428746b89c4d3d7f5a70
- https://github.com/discourse/discourse/security/advisories/GHSA-ff7g-xv79-hgmf
Get alerted when CVE-2023-38684 or the next vulnerability affects your stack