What’s Vulnerable › Vulnerabilities
CVE-2023-38692: Command injection vulnerability in module management function in CloudExplorer Lite
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-04 · updated 2026-06-17
- Weakness: CWE-78
Description
CloudExplorer Lite is an open source, lightweight cloud management platform. Versions prior to 1.3.1 contain a command injection vulnerability in the installation function in module management. The vulnerability has been fixed in v1.3.1. There are no known workarounds aside from upgrading.
Affected products
- CloudExplorer-Dev CloudExplorer-Lite: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: CloudExplorer-Dev CloudExplorer-Lite 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/blob/v1.3.0/framework/management-center/backend/src/main/java/com/fit2cloud/controller/ModuleManageController.java
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/releases/tag/v1.3.1
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-7wrc-f42m-9v5w
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/blob/v1.3.0/framework/management-center/backend/src/main/java/com/fit2cloud/controller/ModuleManageController.java
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/releases/tag/v1.3.1
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-7wrc-f42m-9v5w
Get alerted when CVE-2023-38692 or the next vulnerability affects your stack