What’s Vulnerable › Vulnerabilities
CVE-2023-38693: RCE in Lucee REST endpoint
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-05 · updated 2026-06-17
- Weakness: CWE-611
Description
Lucee Server (or simply Lucee) is a dynamic, Java based, tag and scripting language used for rapid web application development. The Lucee REST endpoint is vulnerable to RCE via an XML XXE attack. This vulnerability is fixed in Lucee 5.4.3.2, 5.3.12.1, 5.3.7.59, 5.3.8.236, and 5.3.9.173.
Affected products
- Lucee: from 5.4.0.0, < 5.4.3.2; from 5.3.12.0, < 5.3.12.1; before 5.3.7.59; from 5.3.8.0, < 5.3.8.236; from 5.3.9.0, < 5.3.9.173
References
Get alerted when CVE-2023-38693 or the next vulnerability affects your stack