What’s Vulnerable › Vulnerabilities
CVE-2023-38706: Discourse vulnerable to DoS via drafts
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-770
Description
Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user can create an unlimited number of drafts with very long draft keys which may end up exhausting the resources on the server. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 3.1.0; through 3.1.0; 3.1.0-beta1, 3.1.0-beta2, 3.1.0-beta3, 3.1.0-beta5, 3.1.0-beta6, 3.1.0-beta7 (+1) — fixed in 3.1.0
How to fix
Upgrade to a fixed version: discourse 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-7wpp-4pqg-gvp8
- https://github.com/discourse/discourse/security/advisories/GHSA-7wpp-4pqg-gvp8
Get alerted when CVE-2023-38706 or the next vulnerability affects your stack