What’s Vulnerable › Vulnerabilities
CVE-2023-38708: Pimcore Path Traversal Vulnerability in AssetController:importServerFilesAction
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-04 · updated 2026-06-17
- Weakness: CWE-22
Description
Pimcore is an Open Source Data & Experience Management Platform: PIM, MDM, CDP, DAM, DXP/CMS & Digital Commerce. A path traversal vulnerability exists in the `AssetController::importServerFilesAction`, which allows an attacker to overwrite or modify sensitive files by manipulating the pimcore_log parameter.This can lead to potential denial of service---key file overwrite. The impact of this vulnerability allows attackers to: overwrite or modify sensitive files, potentially leading to unauthorized access, privilege escalation, or disclosure of confidential information. This could also cause a denial of service (DoS) if critical system files are overwritten or deleted.
Affected products
- pimcore/pimcore: before 10.6.7 — fixed in 10.6.7
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.6.7. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/58012d0e3b8b926fb54eccbd64ec5c993b30c22c
- https://github.com/pimcore/pimcore/security/advisories/GHSA-34hj-v8fm-x887
- https://github.com/pimcore/pimcore/commit/58012d0e3b8b926fb54eccbd64ec5c993b30c22c
- https://github.com/pimcore/pimcore/security/advisories/GHSA-34hj-v8fm-x887
Get alerted when CVE-2023-38708 or the next vulnerability affects your stack