What’s Vulnerable › Vulnerabilities
CVE-2023-38720: IBM Db2 denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM Db2 for Linux, UNIX and Windows (includes Db2 Connect Server) 11.5 and 11.5 is vulnerable to denial of service with a specially crafted ALTER TABLE statement. IBM X-Force ID: 261616.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.5 before 11.5.8; 11.1.4, 11.1.4-fp1, 11.1.4-fp2, 11.1.4-fp3, 11.1.4-fp4, 11.1.4-fp5 (+1) — fixed in 11.5.8
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.5.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/261616
- https://security.netapp.com/advisory/ntap-20231116-0005/
- https://www.ibm.com/support/pages/node/7047489
- https://exchange.xforce.ibmcloud.com/vulnerabilities/261616
- https://security.netapp.com/advisory/ntap-20231116-0005/
- https://www.ibm.com/support/pages/node/7047489
Get alerted when CVE-2023-38720 or the next vulnerability affects your stack