What’s Vulnerable › Vulnerabilities
CVE-2023-38728: IBM Db2 denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM Db2 for Linux, UNIX and Windows (includes Db2 Connect Server) 10.5, 11.1, and 11.5 is vulnerable to denial of service with a specially crafted XML query statement. IBM X-Force ID: 262258.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.5 before 11.5.8; 10.5, 10.5-fp1, 10.5-fp10, 10.5-fp2, 10.5-fp3, 10.5-fp3a (+13) — fixed in 11.5.8
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.5.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/262258
- https://security.netapp.com/advisory/ntap-20231116-0006/
- https://www.ibm.com/support/pages/node/7047489
- https://www.ibm.com/support/pages/node/7047478
- https://exchange.xforce.ibmcloud.com/vulnerabilities/262258
- https://security.netapp.com/advisory/ntap-20231116-0006/
- https://www.ibm.com/support/pages/node/7047489
Get alerted when CVE-2023-38728 or the next vulnerability affects your stack