What’s Vulnerable › Vulnerabilities
CVE-2023-38997
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-09 · updated 2026-06-17
- Weakness: CWE-22
Description
A directory traversal vulnerability in the Captive Portal templates of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary system commands as root via a crafted ZIP archive.
Affected products
- OPNsense: before 23.7 — fixed in 23.7
How to fix
Upgrade to a fixed version: OPNsense 23.7. Check the vendor advisory for mitigations.
References
- https://github.com/opnsense/core/commit/448762d440b51574f1906c0ec2f5ea6dc4f16eb2
- https://logicaltrust.net/blog/2023/08/opnsense.html
- https://github.com/opnsense/core/commit/448762d440b51574f1906c0ec2f5ea6dc4f16eb2
- https://logicaltrust.net/blog/2023/08/opnsense.html
Get alerted when CVE-2023-38997 or the next vulnerability affects your stack