What’s Vulnerable › Vulnerabilities
CVE-2023-3900: Improper Validation of Specified Type of Input in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-02 · updated 2026-06-17
- Weakness: CWE-1287
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. An invalid 'start_sha' value on merge requests page may lead to Denial of Service as Changes tab would not load.
Affected products
- GitLab: from 16.1 before 16.1.3; from 16.2 before 16.2.2 — fixed in 16.1.3, 16.2.2
How to fix
Upgrade to a fixed version: GitLab 16.1.3, 16.2.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/418770
- https://hackerone.com/reports/2058514
- https://gitlab.com/gitlab-org/gitlab/-/issues/418770
- https://hackerone.com/reports/2058514
Get alerted when CVE-2023-3900 or the next vulnerability affects your stack