What’s Vulnerable › Vulnerabilities
CVE-2023-39002
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in the act parameter of system_certmanager.php in OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary web scripts or HTML via a crafted payload.
Affected products
- OPNsense: before 23.7 — fixed in 23.7
How to fix
Upgrade to a fixed version: OPNsense 23.7. Check the vendor advisory for mitigations.
References
- https://github.com/opnsense/core/commit/a4f6a8f8d604271f81984cfcbba0471af58e34dc
- https://logicaltrust.net/blog/2023/08/opnsense.html
- https://github.com/opnsense/core/commit/a4f6a8f8d604271f81984cfcbba0471af58e34dc
- https://logicaltrust.net/blog/2023/08/opnsense.html
Get alerted when CVE-2023-39002 or the next vulnerability affects your stack