What’s Vulnerable › Vulnerabilities
CVE-2023-39004
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-09 · updated 2026-07-09
- Weakness: CWE-732
Description
Insecure permissions in the configuration directory (/conf/) of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allow attackers to access sensitive information (e.g., hashed root password) which could lead to privilege escalation.
Affected products
- OPNsense: before 23.7 — fixed in 23.7
How to fix
Upgrade to a fixed version: OPNsense 23.7. Check the vendor advisory for mitigations.
References
- https://logicaltrust.net/blog/2023/08/opnsense.html
- https://logicaltrust.net/blog/2023/08/opnsense.html
Get alerted when CVE-2023-39004 or the next vulnerability affects your stack