What’s Vulnerable › Vulnerabilities
CVE-2023-39007
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
/ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows XSS via openAction in app/controllers/OPNsense/Cron/ItemController.php.
Affected products
- OPNsense: before 23.7 — fixed in 23.7
How to fix
Upgrade to a fixed version: OPNsense 23.7. Check the vendor advisory for mitigations.
References
- https://github.com/opnsense/core/commit/5edff49db1cd8b5078611e2f542d91c02af2b25c
- https://github.com/opnsense/core/compare/23.1.11...23.7
- https://logicaltrust.net/blog/2023/08/opnsense.html
- https://github.com/opnsense/core/commit/5edff49db1cd8b5078611e2f542d91c02af2b25c
- https://github.com/opnsense/core/compare/23.1.11...23.7
- https://logicaltrust.net/blog/2023/08/opnsense.html
Get alerted when CVE-2023-39007 or the next vulnerability affects your stack