What’s Vulnerable › Vulnerabilities
CVE-2023-39008
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-09 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to execute arbitrary system commands.
Affected products
- OPNsense: before 23.7 — fixed in 23.7
How to fix
Upgrade to a fixed version: OPNsense 23.7. Check the vendor advisory for mitigations.
References
- https://github.com/opnsense/core/commit/e800097d0c287bb665f0751a98a67c75ef7b45e5
- https://logicaltrust.net/blog/2023/08/opnsense.html
- https://github.com/opnsense/core/commit/e800097d0c287bb665f0751a98a67c75ef7b45e5
- https://logicaltrust.net/blog/2023/08/opnsense.html
Get alerted when CVE-2023-39008 or the next vulnerability affects your stack