What’s Vulnerable › Vulnerabilities
CVE-2023-39020
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-28 · updated 2026-06-17
- Weakness: CWE-94
Description
stanford-parser v3.9.2 and below was discovered to contain a code injection vulnerability in the component edu.stanford.nlp.io.getBZip2PipedInputStream. This vulnerability is exploited via passing an unchecked argument.
Affected products
- Stanford Parser: before 4.5.5 — fixed in 4.5.5
How to fix
Upgrade to a fixed version: Stanford Parser 4.5.5. Check the vendor advisory for mitigations.
References
- https://github.com/LetianYuan/My-CVE-Public-References/tree/main/edu_stanford_nlp_stanford-parser
- https://github.com/LetianYuan/My-CVE-Public-References/tree/main/edu_stanford_nlp_stanford-parser
Get alerted when CVE-2023-39020 or the next vulnerability affects your stack