What’s Vulnerable › Vulnerabilities
CVE-2023-3904: Improper Validation of Specified Type of Input in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-15 · updated 2026-06-17
- Weakness: CWE-1287
Description
An issue has been discovered in GitLab EE affecting all versions starting before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. It was possible to overflow the time spent on an issue that altered the details shown in the issue boards.
Affected products
- GitLab: before 16.4.4; from 16.5 before 16.5.4; from 16.6 before 16.6.2 — fixed in 16.4.4, 16.5.4, 16.6.2
How to fix
Upgrade to a fixed version: GitLab 16.4.4, 16.5.4, 16.6.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/418226
- https://hackerone.com/reports/2053154
- https://gitlab.com/gitlab-org/gitlab/-/issues/418226
- https://hackerone.com/reports/2053154
Get alerted when CVE-2023-3904 or the next vulnerability affects your stack