What’s Vulnerable › Vulnerabilities
CVE-2023-3906: Improper Validation of Specified Type of Input in GitLab
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-1287
Description
An input validation issue in the asset proxy in GitLab EE, affecting all versions from 12.3 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1, allowed an authenticated attacker to craft image urls which bypass the asset proxy.
Affected products
- GitLab: from 12.3 before 16.2.8; from 16.3.0 before 16.3.5; 16.4.0 — fixed in 16.2.8, 16.3.5
How to fix
Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/419213
- https://hackerone.com/reports/2071411
- https://gitlab.com/gitlab-org/gitlab/-/issues/419213
- https://hackerone.com/reports/2071411
Get alerted when CVE-2023-3906 or the next vulnerability affects your stack